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I’m Dhilan!
I study Electrical Engineering and 
Computer Science at Harvard.
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with Brian

Harvard

How ML 
works?
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works?

with Dhilan

Harvard
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Camera

Microphone

Last time: Phone
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Microphone

Today: TinyML Kit
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BaŸery & Memory

Less memory

Less compute power

Only focused on inference
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to your tiny devices!

deploy
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TinyML
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Datacenter
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TPUs/GPUs
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Bigger Is Not 
Always Better.
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Latency
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Power

High power
High bandwidth
High latency

Low power
Low bandwidth
Low latency
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Google Assistant



Copyright (c) 2022 TinyMLedu. 
All rights reserved. 
CC BY-NC-SA 4.0

Endpoint Devices
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Biometric Sensors
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Endpoints Have Sensors, Tons of Sensors

Rotation Sensors
Encoders

Force Sensors
Pressure, Strain
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Biometric Sensors

Source: Jacobs School of Engineering/UC San Diego
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Thinking Big
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We’re just getting started.
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Thinking Record-breaking

BIG
GPU / CPU

561mm2

Mobile SoC
83mm2

SMALL
Apple 0778

30mm2

TINY

Kinetis KL03
3.2mm2

world’s smallest 
ARM-Powered MCU

48MHz, 32KB flash, 20-pin
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250 Billion
today
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Challenges

Latency & Bandwidth

Security & Privacy

Accuracy & Personalization

BaŸery & Memory
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Source: Google
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Source: Google
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Less memory

Less compute power

Only focused on inference
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Even less memory

Even less compute power

Also, only focused on inference
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What is Tiny Machine Learning (TinyML)?

TinyML
Fastest-growing ůeld of ML

Algorithms, hardware, software

Low power consumption

On-device sensor analytics

Always-on ML

Battery-operated
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transmit less data!
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language of 
computers
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Microcontroller

Read-Only 
Memory (ROM)

Read-Write 
Memory

Timer I/O Port Serial
Interface

CPU
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Microcontroller: a complete package

CPU

RAMMemory

A/D Converter Timer
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Embedded Systems

Board MCU / ASIC Clock Memory Sensors Radio

Himax
WE-I Plus EVB

HX6537-A
32-bit EM9D DSP 400 MHz 2MB flash

2MB RAM
Accelerometer, Mic, 

Camera None

Arduino
Nano 33 BLE Sense

32-bit
nRF52840 64 MHz 1MB flash

256kB RAM

Mic, IMU, Temp, 
Humidity, Gesture, 
Pressure, Proximity, 

Brightness, Color
BLE

SparkFun
Edge 2

32-bit
ArtemisV1 48 MHz 1MB flash

384kB RAM
Accelerometer, Mic, 

Camera BLE

Espressif
EYE

32-bit
ESP32-D0WD 240 MHz 4MB flash

520kB RAM Mic, Camera WiFi, BLE
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Camera

Microphone
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Purpose

AI-enabled developmental microcontroller board with USB-A to microB cable

Specifications

• nRF52840 MCU (ARM Cortex-M4): 3.3V, 64MHz, 1MB flash, 256 kB RAM
• Sensors on board: microphone, IMU, color, light, proximity, temperature, humidity, and more!
• BLE module with application-adjacent protocol layers (GAP, GATT) covered by ArduinoBLE library

Nano 33 BLE Sense (+ USB cable)
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Purpose

Breakout PCB for tiny camera, for use in person-detection exercises

Specifications

+ Low-voltage, 0.3 MP CMOS VGA (can step down to QVGA, QQVGA) image sensor
+ Serial Camera Control Bus (SCCB) + Camera Parallel Interface (CPI) / Digital Video Port (DVP) interface
+ Breaks ribbon cable out to 2x10 pin array

OV 7675 Camera Module

Purpose

Breakout PCB for tiny camera, for use in person-detection exercises

Specifications

• Low-voltage, 0.3 MP CMOS VGA (can step down to QVGA, QQVGA) image sensor
• Serial Camera Control Bus (SCCB) + Camera Parallel Interface (CPI) / Digital Video Port (DVP) interface
• Breaks ribbon cable out to 2x10 pin array



Copyright (c) 2022 TinyMLedu. 
All rights reserved. 
CC BY-NC-SA 4.0

Purpose

A daughter PCB designed to breakout the IO from the Nano 33 BLE sense to permit easy, 
reliable communication with other local, off-board elements

Specifications

+ Grove connectors (3.3V I2C and simple digital / analog - see pinouts) 
+ 2x10 pin array for OV7675 camera module
+ Voltage input terminal block, accepts 4.5 to 21V (down regulated to 3.3V on Nano 33)

Tiny Machine Learning Shield

Purpose

A daughter PCB designed to breakout the I/O from the Nano 33 BLE sense to permit easy, 
reliable communication with other local, off-board elements

Specifications

• Grove connectors (3.3V I2C and simple digital / analog - see pinouts) 
• 2x10 pin array for OV7675 camera module
• Voltage input terminal block, accepts 4.5 to 21V (down regulated to 3.3V on Nano 33)
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Camera

Microphone
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Installing and Starting the Arduino IDE
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www.arduino.cc/en/software

https://www.arduino.cc/en/software
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www.arduino.cc/en/software

https://www.arduino.cc/en/software
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www.arduino.cc/en/software

https://www.arduino.cc/en/software


Copyright (c) 2022 TinyMLedu. 
All rights reserved. 
CC BY-NC-SA 4.0



Copyright (c) 2022 TinyMLedu. 
All rights reserved. 
CC BY-NC-SA 4.0



Copyright (c) 2022 TinyMLedu. 
All rights reserved. 
CC BY-NC-SA 4.0

right now!

head to Arduino’s software website

www.arduino.cc/en/soft
ware

then download and install

https://www.arduino.cc/en/software
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Install Extras
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Tools → Board → Boards Manager
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Nano 33 BLE
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Nano 33 BLE

3.1.1
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Tools → Manage Libraries…
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Tools → Manage Libraries…
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tensoŴlow



Copyright (c) 2022 TinyMLedu. 
All rights reserved. 
CC BY-NC-SA 4.0

tensoŴlow

Arduino_TensorFlowLite
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tensoŴlow

Version 2.4.0-ALPHA
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Version 2.4.0-ALPHA

Arduino_TensorFlowLite

tensoŴlow
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Install Extras
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767x
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767x

Arduino_OV767X
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767x

Version 0.0.2
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Arduino_OV767X

767x

Version 0.0.2
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767x

Harvard_TinyMLx

Version 1.1.0-ALPHA
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Install Extras
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Arduino_LSM9DS1

9DS1

Version 1.1.0
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ArduinoBLE

Version 1.3.1

ArduinoBLE
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Tools → Board: “[something]” 
        → Arduino Mbed OS Nano Boards  
            →  Arduino Nano 33 BLE
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right now!

PLUG IN via MicroUSB

to your computer
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Tools → Port: “[???] (Arduino Nano 33 BLE)”
        → <???> (Arduino Nano 33 BLE)

set board and port for later

Mac → /dev/cu.usbmodem<#>Windows → COM<#>Linux → ttyUSB<#> or ttyACM<#>
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Testing Your TinyML Kit
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File → Examples 
→ Harvard_TinyMLx 

→ test_microphone
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upload

done?
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Double Tap Reset for 

Bootloader Mode!
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Tools → Serial Monitor
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Tools → Serial Monitor
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9600 
baud

Both! 
NL & CR

Tools → Serial Monitor

click
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Tools → Serial Monitor

Send



Copyright (c) 2022 TinyMLedu. 
All rights reserved. 
CC BY-NC-SA 4.0

NUMBERS 
FLYING BY

Tools → Serial Monitor
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Tools → Serial Plotter
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Tools → Serial Plotter

How clean of a wave can you get?
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Deploying KWS model onto Arduino
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Reduces the precision of numbers used in 
a model which results in:

- smaller model size
- faster computation

Quantization
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float32

0

max(|xf|)

min(|xf|)

0

int8

127

-128

Reducing the Precision

4 bytes per 
model 

parameter

1 byte per 
model 

parameter

max: 3.40282e+38 
min: 1.17549e-38
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Floating-point 
Baseline After Quantization Accuracy 

Drop

MobileNet v1 1.0 224 71.03% 69.57% ▾1.46%

MobileNet v2 1.0 224 70.77% 70.20% ▾0.57%

Resnet v1 50 76.30% 75.95% ▾0.35%

Tradeoff
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float32 int8
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float32 int8
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float32 int8
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YOUR_PROJECT_NAME
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Sketch → Include Library 
→ Add .ZIP Library
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YOUR_PROJECT_NAME
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File → Examples →               
  YOUR_PROJECT_NAME →      
    nano_ble33_sense_microphone

YOUR_PROJECT_NAME
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upload
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done?
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Double Tap Reset for 

Bootloader Mode!
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Tools → Serial Monitor
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Confidence that the audio 
is one of the choices (0-1 scale)
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Review + Why Tiny?

Hardware Basics

Installing and Starting the Arduino IDE

Testing Your TinyML Kit

Deploying KWS model onto Arduino

Summary & Next Steps

Today’s Agenda

Summary & Next Steps
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Machine
Learning

ANSWERS
WE PROVIDE

INPUTS RULES

THE 
COMPUTER 

LEARNS

LABELS
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Deep Learning
with Neural Networks
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Features

Features can be found with Convolutions

-1 0 1

-2 0 2

-1 0 1

Colab Link

https://colab.research.google.com/github/tinyMLx/colabs/blob/master/2-3-3-ExploringConvolutions.ipynb


Copyright (c) 2022 TinyMLedu. 
All rights reserved. 
CC BY-NC-SA 4.0

Collect & 
Transform

Data

Design & 
Train

 a Model

Convert
Model

Deploy
Model

Make
Inferences

The (Tiny) Machine Learning Workflow

 ML is everywhere → collect GOOD 
data RESPONSIBLY
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Collect & 
Transform

Data

Design & 
Train

 a Model

Convert
Model

Deploy
Model

Make
Inferences

The (Tiny) Machine Learning Workflow
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Collect & 
Transform

Data

Design 
& Train

 a Model

Convert
Model

Deploy
Model

Make
Inferences

The (Tiny) Machine Learning Workflow
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The (Tiny) Machine Learning Workflow
Collect 

Data

Design & 
Train

 a Model

Deploy
Model

Make
Inferences

Edge Impulse Simplifies 
Training and Deployment
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Collect & 
Transform

Data

Deploy 
Model

Convert
Model

Design & Train
 a Model

The (Tiny) Machine Learning Workflow

Even less memory

Even less compute power

Also, only focused on inference

Make 
Inferences
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Confidence that the audio 
is one of the choices (0-1 scale)
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Workshop Agenda

Introduction to AI and (Tiny)ML Cloud MLDay 1

Keyword Spotting for the Navajo Language Mobile MLDay 2

Bringing AI/ML from the Cloud to the Edge Embedded MLDay 3

161
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Workshop Agenda

Introduction to AI and (Tiny)ML Cloud MLDay 1

Keyword Spotting for the Navajo Language Mobile MLDay 2

Bringing AI/ML from the Cloud to the Edge Embedded MLDay 3

162
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Practice with more 
machine learning!
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Practice with more Machine Learning

experiments.withgoogle.com
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teachablemachine.withgoogle.com
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edgeimpulse.com
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3Blue1Brown
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coursera
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coursera
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edx.org
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hackster.io
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home base for all information!

tinyMLedu.org/EASI-22

Our website!
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help us make this workshop better!

bit.ly/EASI22-Post

survey!
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with help from many more
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thank you and keep exploring with ML

hágoóneeʼ 👋


